Back to overview
Degraded
Degraded Performance
Oct 21 at 09:00am NZDT
Affected services
SafeStack Learning Platform
Resolved
Oct 21 at 08:00pm NZDT
The incident has been resolved.
Affected services
Updated
Oct 21 at 02:00pm NZDT
Our monitoring indicates that most services should be back to normal.
Affected services
Created
Oct 21 at 09:00am NZDT
We are experiencing some performance degradation due to the ongoing increased error rates and latencies with AWS. Our engineering team remains actively engaged in monitoring AWS status updates and applying necessary mitigations to reduce impact. Thank you for your continued patience as we work through these challenges.
Affected services